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Program Description
This data editor provides a convenient tool for the management of coordinates, data
transfer and DXF export. Coordinates can be filtered out from all Zeiss formats for
processing. Three additional formats can be freely defined. Data conversion is possible
between any of the different formats. The program also creates the project-related CTL
file for Rec Elta C instruments. The DXF export function enables editing of a coordinates
file for virtually any CAD program. Data transfer permits loading down the measured data
and coordinates stored in the instrument, and transmitting the edited coordinates back to
the instrument.

Installation
If the program is available on an installation disk, proceed as follows:
Select Windows Start->Run and start the setup.exe file on the disk. For the execution of
the installation process, follow the user guidance of the program.
If the program is available in the form of packed files, proceed as follows:
Create your target directory using the Windows explorer (or another suitable program) and
copy the files from the disk to this directory. Unpack the packed files with pkunzip.exe
(pkunzip filename.zip). Then click the Windows user interface with the right mouse button
and select New->Shortcut. Now select the zeissed.exe file and enter the name ZeissEd.
The ZeissEd icon will then be available on the desktop. The installation of the program is
now completed.

After the installation, you have to configure the program to suit your specific requirements.
The following sequence is recommended for this process:

- Adapt the paths
- Configure the file formats
- Set the data transfer parameters
- Configure the DXF parameters
- Select the CTL standard file (for Rec Elta C instruments only)

The following describes the configuration procedure in more detail.
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Configuration

Data directory

The path for the data is set with Configuration->Path. The selected path will subsequently
be offered by default.

Formats

The program supports the following file formats:

Rec 500 - Rec 500, Rec Elta 
M5 - Rec Elta, Elta S, Elta R
R4 - Elta 40R, 50R
R5 - Elta 40R, 50R

and

three freely selectable formats

In the fixed formats, the digits for the coordinates have been preset and cannot be
changed. The digits for the point number and code can be varied by the user as required,
by specifying the respective start and end digits. These settings are stored in the
configuration file and will be available when the program is called up the next time. 
In the free formats, you have to set not only the digits for the point number and code, but
also those for the coordinates and the record length. The assigned name is stored and will
be available for further use.

File format configuration 

To configure the formats, select Configuration->File formats. 
In the  Zeiss M5 and Rec 500 formats, you have to define the digits for the point number
and code. In the Zeiss R4 and R5 formats, the digits for the point number and code only
need to be changed if you want to use code characters for the point number or vice versa.
In the free formats, you have to define the complete layout. The annex gives examples of
common free formats. When specifying the digits, you always have to start counting at the
beginning of the line. 
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Marking for Rec 500 and M5 formats
0        1         2                  
123456789012345678901234567
<------------><----------->

To define the digits for the point number and code, call up the relevant marking on the
instrument and count the digits. Add 8 to the starting and end values for Rec 500 and 21
to those for M5, and enter the appropriate values for the configuration of the file formats.

Data transfer parameters

To set the data transfer parameters, select Data transfer->Parameters. You can define
profiles for up to five instruments. 
Set the parameters as required for the instrument concerned. An overview of the
parameters for the different instruments is included in the annex.

Note! Remember to specify the correct interface.
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DXF parameters

The DXF export function supports the connection of two successive points by a line. If you
want to use this function, you have to make an appropriate entry for this coding in
Configuration->DXF configuration->Source file. If you enter '0', the connecting line is
ignored.

For the output in the DXF format, you can set the size and digits for the point number and
elevation. The optimum values are dependent on the scale to be subsequently used and
should therefore be selected to meet your specific requirements.  If the coordinates
appear wrong-reading in the CAD program, you can exchange their positions using the
button 'Exchange Y and X' .

CTL file

To create a CTL file, you have to specify a standard CTL file. Copy this file from the
PCMCIA card of the instrument to the data directory. The file has to originate from a
project in which the markings you use have been defined. The file is stored via
Configuration >Path and is subsequently used as the standard format for the creation of
CTL files.
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Program functions

New file

Select File >New to create a new file. Enter the file name and the format to be used. 
By default, the program searches for all files with the extension DAT. However, you can
also select other filters in the File type menu.

Open file

Select  File->Open to open an existing file. If no file format is specified, the program
automatically tries to identify the format of the opened file.

If the format cannot  be identified, an enquiry is displayed and you have to enter the
format manually.

Edit data

Once a file has been opened, you can enter and edit coordinates in it. 
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Use the ñ and ò cursor keys to select the record required and press the Return key for
editing. Select 'Paste' to insert a new record at the current position or cursor ò to add a
new record at the end of the file.

The point number, code, Y, X and Z coordinates of each record are managed. 
For the point number and code, you have the option of left-adjusted, right-adjusted or
unformatted storage. 

DXF export

An open coordinates file is exported in the DXF format via Export->DXF. For this purpose,
a 3D point information is generated, which contains separate layers for point symbol, point
number and elevation. If connecting lines are used, successive points are connected in
accordance with these specifications. 

Conversion

The program permits you to save a loaded file in a different format by selecting either File-
> Save as or Export->Other format.
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In addition to the file name, you have to specify the target format. If you use File-> Save
as, the current file will afterwards be processed with the new name and format. If you use
Export->Other format, the current file will keep its name and format, and a new file with the
changed specifications will be saved.
In data conversion between different formats, it is essential that the point number and
code are transferred in a formatted way if the two formats provide a different number of
digits for this data.  

CTL file

In the Zeiss Rec Elta C instruments, each project must be associated with a so-called CTL
file containing the preset markings, the maximum number of records and other settings. If
you edit a project or create a new one using the data editor, it is also necessary to create
the corresponding CTL file. This is done via Tools->Create M5 CTL file. 

Specify the coordinates file for which the CTL file is to be created, the maximum number
of data records required in the project, the standard CTL file and the new CTL file.
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Notes on the CTL file:

A control file is required for each project (M5 file) on the PCMCIA card. It is generated by
the instrument when the new project is created. The CTL file contains such information as
the preset markings, the current marking, the maximum number of records and the current
record. 
If you want to delete a project from the card, you can do this either via the instrument's
project management or by manually deleting the *.DAT file and the associated control file.
Both files must always be deleted together!
If you want to edit or delete coordinates of a data file on the PC, you have to create a new
CTL file using  Tools->Create M5 CTL file. This file is then copied back to the card,
together with the coordinates file. First, however, you have to delete the old file from the
card.

The CTL files are continuously numbered. The CTL file which is currently active has the
name ctl$$$xx.000, all others are named ctl$$$xx.cfg with 'xx' standing for the
consecutive number. Some CTL files should therefore be named ctl$$$yy.cfg, with 'yy'
standing for a number which does not yet exist on the PCMCIA card.

Data transfer

Data transfer from and to the instrument is possible. First, you should check the settings
for the interface on the instrument and in the program.

To receive data from the instrument, select Data transfer->Receive data from Elta. After
you have specified the file name, the program switches to the reception mode. You can
now start the transfer on the instrument. 

After successful completion of the transfer, the received data is displayed on the screen
and saved in the specified file. 

To transmit data to the instrument, select Data transfer->Send data to Elta. After selecting
the file to be transmitted, set the instrument to data transfer to make it ready for reception.

Select 'Start' to start the transfer.
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Annex

File formats

Example of Rec 500 format:

0        1         2                  
123456789012345678901234567
<------------><----------->
Point-No_Cod_Comment-----

Start End

Point number 1+8 = 9 8+8 = 16
Code 10+8 = 18 12+8 = 20

Example of M5 format:

0        1         2                  
123456789012345678901234567
<------------><----------->
Point-No_Cod_Comment-----

Start End

Point number 1+21 = 22 8+21 = 29
Code 10+21 = 31 12+21 = 33

Examples of free formats:

Caddy KOR Start End Digits after Dec. Point

Point number 1 15

Code 58 59

Y coordinate 18 30 3

X coordinate 33 45 3

Z coordinate 48 56 3

Record length 60

VermOn Start End Digits after Dec. Point

Point number 2 9
Code 55 56

Y coordinate 11 23 5

X coordinate 25 37 5

Z coordinate 39 48 5

Record length 68
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Blank tables for your data formats:

Start End Digits after Dec. Point

Point

Code

Y coordinate

X coordinate

Z coordinate

Record length

Start End Digits after Dec. Point

Point
Code

Y coordinate

X coordinate

Z coordinate

Record length
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Data Transfer Parameters

We recommend the following parameter settings for data transfer:

Instrument Baud Data Bits Parity Stop Bits Handshake Timeout

Rec 500 4800 8 none 2 XON/XOFF 1

Rec Elta 9600 8 none 1 XON/XOFF 1
Elta R 9600 7 even 2 XON/XOFF 1

DiNi 9600 8 kein 1 XON/XOFF 1

Attention! For data transfer using Rec 500, you have to select the 'Printer' interface on
Rec 500.

Files

The delivery package includes the following files:

bds501f.dll - DLL
cw3220.dll - DLL
owl501f.dll - DLL
supercom.dll - DLL
sernr.cfg - key file containing the serial number
zeissed.cfg - configuration file
zeissed.exe - program
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ZeissEd data editor for Win 95 / Win NT

developed by:

Sinning Vermessungsbedarf GmbH
Korbacher Str. 15
D-97353 Wiesentheid
Tel. +49 93 32 / 97 32 - 0
Fax +49 93 32 / 97 32 - 10
eMail sinning@sinning.de
Internet http://www.sinning.de

The program is continuously upgraded. We are therefore grateful for your suggestions and
for the description of errors that have occurred. We would also appreciate if you could
inform us about any file format settings not yet included in the annex. 

In the event of errors, please use the attached form or send us an e-mail. Please also
address your enquiries and suggestions to us by e-mail; they will promptly be answered.

Updates for error correction and minor functional enhancements are available free of
charge in the Internet for downloading. On request, we will also be glad to send you a disk
with the update required and the current manual against a charge of currently DM 50.00.
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